Required Password Update

Dear ABI Research Client:

On April 7th, 2014, a vulnerability was announced in the OpenSSL cryptographic software library. Secure Socket Layers or SSL are the most popular form of encryption for internet traffic, used by an estimated two-thirds of all websites.

The issue has been widely covered by the media, and is affecting millions of companies. More information about this vulnerability is available here: http://heartbleed.com.

Although ABI Research has no evidence of any compromise of passwords, accounts or data, our strict security protocol requires us to err on the side of caution.

Our systems have been updated to address the heartbleed vulnerability, and we are requiring all of our users to reset their passwords.

A password reset e-mail has just been sent to your e-mail address on record. Following the link provided by the e-mail will bring you to a page where you can update your password.

We apologize for any inconvenience and we hope that you see our immediate and direct response to this internationally announced vulnerability as representative of our commitment to security for all of our clients and website users.

If you have any issues updating your password, questions about the vulnerabilty, or comments about our response, please let us know.

Sincerely,
ABI Research IT Team